NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2016-1927 — phpmyadmin

HIGHFix: phpmyadmin/phpmyadmin@8dedcc1

CVE-2016-1927 is a high-severity (CVSS 7.5) CWE-254 vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin Cryptographic Vulnerability

Also known asGHSA-4gmg-gwjh-3mmr
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.01%1.11%2.21%3.31%0.6%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The suggestPassword function in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 relies on the Math.random JavaScript function, which makes it easier for remote attackers to guess passwords via a brute-force approach.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.0.0&&< 4.0.10.134.0.10.13composer require phpmyadmin/phpmyadmin:^4.0.10.13
🐘Packagistphpmyadmin/phpmyadmin≥ 4.4.0&&< 4.4.15.34.4.15.3composer require phpmyadmin/phpmyadmin:^4.4.15.3
🐘Packagistphpmyadmin/phpmyadmin≥ 4.5.0&&< 4.5.44.5.4composer require phpmyadmin/phpmyadmin:^4.5.4

Affected Products

1 product · 45 configurations
Application
phpmyadminphpmyadmin
43 versions
4.0.04.0.14.0.104.0.10.14.0.10.24.0.10.34.0.10.44.0.10.54.0.10.64.0.10.74.0.10.84.0.10.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.0.10.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-1927 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The suggestPassword function in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 relies on the Math.random JavaScript function, which makes it easier for remote attackers to guess passwords via a brute-force approach.
O3 Security · Impact-Aware SCA

Is CVE-2016-1927 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-1927: phpmyadmin — Fixed in 4.0.10.13