NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2015-8379 — cakephp

HIGHFix: cakephp/cakephp@0f818a2

CVE-2015-8379 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in cakephp/cakephp. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for cakephp/cakephp — see the affected versions and patch details below.

CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter

Also known asGHSA-556q-h4vr-pgh2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.63%1.27%1.90%0.1%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘cakephp/cakephp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF protection mechanism via the _method parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcakephp/cakephp≥ 2.0.0-alpha&&< 3.1.53.1.5composer require cakephp/cakephp:^3.1.5

Affected Products

1 product · 137 configurations
Application
cakephpcakephp
100 versions
2.0.02.0.12.0.22.0.32.0.42.0.52.0.62.1.02.1.12.1.22.1.32.1.4
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cakephp/cakephp to 3.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8379 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF protection mechanism via the _method parameter.
O3 Security · Impact-Aware SCA

Is CVE-2015-8379 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-8379: cakephp CSRF — Fixed in 3.1.5