NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2015-7713 — nova

CVE-2015-7713 is a CWE-254 vulnerability in nova. A fix is available for nova — see the affected versions and patch details below.

OpenStack Compute (Nova) allows remote attackers to bypass intended restriction

Also known asGHSA-67rh-9p29-vrxrPYSEC-2026-867
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.87%2.03%3.19%4.35%1.5%3.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐍nova🐍nova

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Compute (Nova) before 2014.2.4 (juno) and 2015.1.x before 2015.1.2 (kilo) do not properly apply security group changes, which allows remote attackers to bypass intended restriction by leveraging an instance that was running when the change was made.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInovaall versions2014.2.4pip install --upgrade 'nova==2014.2.4'
🐍PyPInova≥ 2015.1.0&&< 2015.1.22015.1.2pip install --upgrade 'nova==2015.1.2'

Affected Products

1 product · 2 configurations
Application
novaopenstack
≥ 2015.1.0 && < 2015.1.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nova to 2014.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7713 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6openstack-nova-0:2014.1.5-16.el6ostRHSA-2016:0017
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7openstack-nova-0:2014.1.5-9.el7ostRHSA-2015:2684
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7openstack-nova-0:2014.2.3-42.el7ostRHSA-2016:0013
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7openstack-nova-0:2015.1.2-7.el7ostRHSA-2015:2673

Frequently Asked Questions

OpenStack Compute (Nova) before 2014.2.4 (juno) and 2015.1.x before 2015.1.2 (kilo) do not properly apply security group changes, which allows remote attackers to bypass intended restriction by leveraging an instance that was running when the change was made.
O3 Security · Impact-Aware SCA

Is CVE-2015-7713 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-7713: nova — Fixed in 2014.2.4