NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2015-7546 — keystone

HIGHFix: openstack/keystone@bff03b5

CVE-2015-7546 is a high-severity (CVSS 7.5) CWE-522 vulnerability in keystone. A fix is available for keystone — see the affected versions and patch details below.

OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials

Also known asGHSA-8c4w-v65p-jvcvPYSEC-2016-20PYSEC-2026-2549
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.85%1.71%2.56%0.1%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐍keystone🐍keystonemiddleware🐍keystone🐍keystonemiddleware🐍keystonemiddleware

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkeystone≥ 9.0.0.0b1&&< 9.0.0.0b29.0.0.0b2pip install --upgrade 'keystone==9.0.0.0b2'
🐍PyPIkeystonemiddleware≥ 2.4.0&&< 4.1.04.1.0pip install --upgrade 'keystonemiddleware==4.1.0'
🐍PyPIkeystone≥ 8.0&&< 8.1.08.1.0pip install --upgrade 'keystone==8.1.0'
🐍PyPIkeystonemiddlewareall versions1.5.4pip install --upgrade 'keystonemiddleware==1.5.4'
🐍PyPIkeystonemiddleware≥ 1.6.0&&< 2.3.32.3.3pip install --upgrade 'keystonemiddleware==2.3.3'

Affected Products

3 products · 5 configurations
Application
keystoneopenstack
≥ 2015.1.0 && ≤ 2015.1.2
range
Application
keystonemiddlewareopenstack
≥ 1.6.0 && ≤ 2.3.2
range
OS
solarisoracle
1 version
11.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update keystone to 9.0.0.0b2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7546 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.
O3 Security · Impact-Aware SCA

Is CVE-2015-7546 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-7546: keystone — Fixed in 9.0.0.0b2