CVE-2015-5286 — glance
CVE-2015-5286 is a CWE-264 vulnerability in glance. A fix is available for glance — see the affected versions and patch details below.
OpenStack Image Service (Glance) allows remote authenticated users to bypass storage quota, cause denial of service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
glance🐍glanceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Image Service (Glance) before 2014.2.4 (juno) and 2015.1.x before 2015.1.2 (kilo) allows remote authenticated users to bypass the storage quota and cause a denial of service (disk consumption) by deleting images that are being uploaded using a token that expires during the process. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-9623.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | glance | all versions | 2014.2.4pip install --upgrade 'glance==2014.2.4' |
| 🐍PyPI | glance | ≥ 2015.1.0&&< 2015.1.2 | 2015.1.2pip install --upgrade 'glance==2015.1.2' |
Affected Products
image registry and delivery service \(glance\)openstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for glance, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update glance to 2014.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5286 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | openstack-glance-0:2014.1.5-3.el6ost | RHSA-2015:1897 |
Frequently Asked Questions
Is CVE-2015-5286 in your dependencies?
Find it across PyPI, including transitive dependencies.