CVE-2015-3280 — nova
CVE-2015-3280 is a CWE-399 vulnerability in nova. A fix is available for nova — see the affected versions and patch details below.
OpenStack Compute (nova) allows remote authenticated users to cause a denial of service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
nova🐍novaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Compute (nova) before 2014.2.4 (juno) and 2015.1.x before 2015.1.2 (kilo) does not properly delete instances from compute nodes, which allows remote authenticated users to cause a denial of service (disk consumption) by deleting instances while in the resize state.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nova | all versions | 2014.2.4pip install --upgrade 'nova==2014.2.4' |
| 🐍PyPI | nova | ≥ 2015.1.0&&< 2015.1.2 | 2015.1.2pip install --upgrade 'nova==2015.1.2' |
Affected Products
novaopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nova to 2014.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3280 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | openstack-nova-0:2014.1.5-3.el6ost | RHSA-2015:1898 |
Frequently Asked Questions
Is CVE-2015-3280 in your dependencies?
Find it across PyPI, including transitive dependencies.