CVE-2015-3257 — zend-diactoros
MEDIUMCVE-2015-3257 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in zendframework/zend-diactoros. A fix is available for zendframework/zend-diactoros — see the affected versions and patch details below.
zend-diactoros Cross-site Scripting (XSS)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zendframework/zend-diactorosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Zend/Diactoros/Uri::filterPath in zend-diactoros before 1.0.4 does not properly sanitize path input, which allows remote attackers to perform cross-site scripting (XSS) or open redirect attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zend-diactoros | ≥ 1.0.0&&< 1.0.4 | 1.0.4composer require zendframework/zend-diactoros:^1.0.4 |
Affected Products
diactoroszendDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zend-diactoros, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zend-diactoros to 1.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3257 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2015-3257 in your dependencies?
Find it across Packagist, including transitive dependencies.