Zend-Diactoros URL Rewrite vulnerabilityGHSA-fq4p-86hh-42v9
MEDIUMFix: zendframework/zend-diactoros@3a4f44fGHSA-fq4p-86hh-42v9 is a medium-severity (CVSS 4.7) vulnerability in zendframework/zend-diactoros. A fix is available for zendframework/zend-diactoros — see the affected versions and patch details below.
Real-World Exposure
zendframework/zend-diactorosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
zend-diactoros (and, by extension, Expressive), zend-http (and, by extension, Zend Framework MVC projects), and zend-feed (specifically, its PubSubHubbub sub-component) each contain a potential URL rewrite exploit. In each case, marshaling a request URI includes logic that introspects HTTP request headers that are specific to a given server-side URL rewrite mechanism.
When these headers are present on systems not running the specific URL rewriting mechanism, the logic would still trigger, allowing a malicious client or proxy to emulate the headers to request arbitrary content.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zend-diactoros | ≥ 1.0.0&&< 1.8.4 | 1.8.4composer require zendframework/zend-diactoros:^1.8.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zend-diactoros, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zend-diactoros to 1.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fq4p-86hh-42v9 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-fq4p-86hh-42v9 in your dependencies?
Find it across Packagist, including transitive dependencies.