CVE-2014-5251 is a medium-severity (CVSS 6.5) CWE-255 vulnerability in keystone. A fix is available for keystone — see the affected versions and patch details below.
OpenStack Identity (Keystone) Multiple vulnerabilities in revocation events
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
keystoneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The MySQL token driver in OpenStack Identity (Keystone) 2014.1.x before 2014.1.2.1 and Juno before Juno-3 stores timestamps with the incorrect precision, which causes the expiration comparison for tokens to fail and allows remote authenticated users to retain access via an expired token.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | keystone | all versions | 8.0.0a0pip install --upgrade 'keystone==8.0.0a0' |
Affected Products
ubuntu linuxcanonicalkeystoneopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update keystone to 8.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-5251 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue does not affected openstack-keystone as shipped with Red Hat Enterprise Linux OpenStack Platform 4.0.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | openstack-keystone-0:2014.1.2.1-2.el6ost | RHSA-2014:1122 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | openstack-keystone-0:2014.1.2.1-1.el7ost | RHSA-2014:1121 |
Frequently Asked Questions
Is CVE-2014-5251 in your dependencies?
Find it across PyPI, including transitive dependencies.