NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2014-3607 — vt-ldap

MEDIUM

CVE-2014-3607 is a medium-severity (CVSS 5.9) CWE-295 vulnerability in edu.vt.middleware:vt-ldap. A fix is available for edu.vt.middleware:vt-ldap — see the affected versions and patch details below.

Improper Certificate Validation in vt-ldap

Also known asGHSA-273v-g3x4-r3rc
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.91%1.37%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕edu.vt.middleware:vt-ldap☕edu.internet2.middleware:shibboleth-identityprovider

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

DefaultHostnameVerifier in Ldaptive (formerly vt-ldap) does not properly verify that the server hostname matches a domain name in the subject's Common Name (CN) field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenedu.vt.middleware:vt-ldapall versions3.3.8edu.vt.middleware:vt-ldap:3.3.8
☕Mavenedu.internet2.middleware:shibboleth-identityproviderall versions2.4.2edu.internet2.middleware:shibboleth-identityprovider:2.4.2

Affected Products

2 products · 2 configurations
Application
ldaptiveldaptive
< 1.0.5
range
Application
vt-ldapldaptive
< 3.3.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for edu.vt.middleware:vt-ldap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update edu.vt.middleware:vt-ldap to 3.3.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3607 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

DefaultHostnameVerifier in Ldaptive (formerly vt-ldap) does not properly verify that the server hostname matches a domain name in the subject's Common Name (CN) field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
O3 Security · Impact-Aware SCA

Is CVE-2014-3607 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3607: vt-ldap — Fixed in 3.3.8