NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2014-3603 — shibboleth-identityprovid…

MEDIUM

CVE-2014-3603 is a medium-severity (CVSS 5.9) CWE-297 vulnerability in edu.internet2.middleware:shibboleth-identityprovider. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for edu.internet2.middleware:shibboleth-identityprovider — see the affected versions and patch details below.

Improper Validation of Certificate with Host Mismatch in Shibboleth Identity Provider and OpenSAML Java

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.34%0.1%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕edu.internet2.middleware:shibboleth-identityprovider☕org.opensaml:opensaml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The (1) HttpResource and (2) FileBackedHttpResource implementations in Shibboleth Identity Provider (IdP) before 2.4.1 and OpenSAML Java 2.6.2 do not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenedu.internet2.middleware:shibboleth-identityproviderall versions2.4.1edu.internet2.middleware:shibboleth-identityprovider:2.4.1
☕Mavenorg.opensaml:opensamlall versions2.6.2org.opensaml:opensaml:2.6.2

Affected Products

2 products · 2 configurations
Application
identity providershibboleth
< 2.4.1
range
Application
opensaml javashibboleth
< 2.6.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for edu.internet2.middleware:shibboleth-identityprovider, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update edu.internet2.middleware:shibboleth-identityprovider to 2.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3603 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The (1) HttpResource and (2) FileBackedHttpResource implementations in Shibboleth Identity Provider (IdP) before 2.4.1 and OpenSAML Java 2.6.2 do not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
O3 Security · Impact-Aware SCA

Is CVE-2014-3603 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3603: shibboleth-identityprovid… — Fixed in 2.4.1