NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2011-1411 — opensaml

CVE-2011-1411 is a Improper Authentication vulnerability in org.opensaml:opensaml. A fix is available for org.opensaml:opensaml — see the affected versions and patch details below.

Improper Authentication in OpenSAML

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.96%1.93%2.89%0.3%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.opensaml:opensaml☕org.opensaml:opensaml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Shibboleth OpenSAML library 2.4.x before 2.4.3 and 2.5.x before 2.5.1, and IdP before 2.3.2, allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack."

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.opensaml:opensaml≥ 2.4.0&&< 2.4.32.4.3org.opensaml:opensaml:2.4.3
☕Mavenorg.opensaml:opensaml≥ 2.5.0&&< 2.5.12.5.1org.opensaml:opensaml:2.5.1

Affected Products

2 products · 15 configurations
Application
opensamlshibboleth
4 versions
2.4.02.4.12.4.22.5.0
Application
shibboleth-identity-providershibboleth
≤ 2.3.1
10 versions
2.0.02.1.02.1.12.1.22.1.32.1.42.1.52.2.02.2.12.3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensaml:opensaml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.opensaml:opensaml to 2.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-1411 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Shibboleth OpenSAML library 2.4.x before 2.4.3 and 2.5.x before 2.5.1, and IdP before 2.3.2, allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack."
O3 Security · Impact-Aware SCA

Is CVE-2011-1411 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2011-1411: opensaml — Fixed in 2.4.3