NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2014-3517 — nova

CVE-2014-3517 is a Information Exposure vulnerability in nova. A fix is available for nova — see the affected versions and patch details below.

OpenStack Compute (Nova) Exposure of Sensitive Information to an Unauthorized Actor vulnerability

Also known asGHSA-xjmj-p278-4jp5PYSEC-2026-884
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.82%1.64%2.45%0.4%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐍nova🐍nova

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

api/metadata/handler.py in OpenStack Compute (Nova) before 2013.2.4, 2014.x before 2014.1.2, and Juno before Juno-2, when proxying metadata requests through Neutron, makes it easier for remote attackers to guess instance ID signatures via a brute-force attack that relies on timing differences in responses to instance metadata requests.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInovaall versions2013.2.4pip install --upgrade 'nova==2013.2.4'
🐍PyPInova≥ 2014.0.0&&< 2014.1.22014.1.2pip install --upgrade 'nova==2014.1.2'

Affected Products

1 product · 3 configurations
Application
novaopenstack
≥ 2014.1 && ≤ 2013.2.4
1 version
2014.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nova to 2013.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3517 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack 4 for RHEL 6openstack-nova-0:2013.2.3-12.el6ostRHSA-2014:1084
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7openstack-nova-0:2014.1.1-4.el7ostRHSA-2014:0940

Frequently Asked Questions

api/metadata/handler.py in OpenStack Compute (Nova) before 2013.2.4, 2014.x before 2014.1.2, and Juno before Juno-2, when proxying metadata requests through Neutron, makes it easier for remote attackers to guess instance ID signatures via a brute-force attack that relies on timing differences in responses to instance metadata requests.
O3 Security · Impact-Aware SCA

Is CVE-2014-3517 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2014-3517: nova — Fixed in 2013.2.4