CVE-2014-0162 — glance
CVE-2014-0162 is a Improper Input Validation vulnerability in glance. A fix is available for glance — see the affected versions and patch details below.
OpenStack Image Registry and Delivery Service (Glance) Improper Input Validation vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
glanceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The Sheepdog backend in OpenStack Image Registry and Delivery Service (Glance) 2013.2 before 2013.2.4 and icehouse before icehouse-rc2 allows remote authenticated users with permission to insert or modify an image to execute arbitrary commands via a crafted location.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | glance | ≥ 2013.2&&< 2013.2.4 | 2013.2.4pip install --upgrade 'glance==2013.2.4' |
Affected Products
icehouseopenstackimage registry and delivery service \(glance\)openstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for glance, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update glance to 2013.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0162 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack 4 for RHEL 6 | openstack-glance-0:2013.2.2-3.el6ost | RHSA-2014:0455 |
Frequently Asked Questions
Is CVE-2014-0162 in your dependencies?
Find it across PyPI, including transitive dependencies.