NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2013-6289 — solr

MEDIUMFix: TYPO3-Solr/ext-solr@57e3b06

CVE-2013-6289 is a medium-severity (CVSS 4.3) Cross-site Scripting (XSS) vulnerability in apache-solr-for-typo3/solr. A fix is available for apache-solr-for-typo3/solr — see the affected versions and patch details below.

Apache Solr for TYPO3 (solr) extension is vulnerable to Cross-site scripting (XSS)

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.77%1.54%2.31%0.3%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘apache-solr-for-typo3/solr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistapache-solr-for-typo3/solrall versions2.8.3composer require apache-solr-for-typo3/solr:^2.8.3

Affected Products

1 product · 10 configurations
Application
apache solringo_renner
≤ 2.8.2
9 versions
1.01.3.01.3.12.1.02.2.02.2.12.2.22.8.02.8.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-solr-for-typo3/solr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apache-solr-for-typo3/solr to 2.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-6289 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2013-6289 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-6289: solr XSS — Fixed in 2.8.3