NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2013-6288 — solr

CRITICAL

CVE-2013-6288 is a critical-severity (CVSS 9.8) vulnerability in apache-solr-for-typo3/solr. A fix is available for apache-solr-for-typo3/solr — see the affected versions and patch details below.

Apache Solr for TYPO3 (solr) extension is vulnerable to Insecure Unserialize

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.07%0.96%1.85%2.73%0.6%2.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘apache-solr-for-typo3/solr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Unspecified vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 has unknown impact and remote attack vectors, related to "Insecure Unserialize."

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistapache-solr-for-typo3/solrall versions2.8.3composer require apache-solr-for-typo3/solr:^2.8.3

Affected Products

1 product · 10 configurations
Application
apache solringo_renner
≤ 2.8.2
9 versions
1.01.3.01.3.12.1.02.2.02.2.12.2.22.8.02.8.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-solr-for-typo3/solr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apache-solr-for-typo3/solr to 2.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-6288 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Unspecified vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 has unknown impact and remote attack vectors, related to "Insecure Unserialize."
O3 Security · Impact-Aware SCA

Is CVE-2013-6288 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-6288: solr — Fixed in 2.8.3