CVE-2013-4751 — validator
HIGHCVE-2013-4751 is a high-severity (CVSS 8.1) Improper Input Validation vulnerability in symfony/validator. A fix is available for symfony/validator — see the affected versions and patch details below.
Symfony collectionCascaded and collectionCascadedDeeply fields security bypass
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/validator🐘symfony/validator🐘symfony/validator🐘symfony/validator🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfonyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
When using the Validator component, if Symfony\\Component\\Validator\\Mapping\\Cache\\ApcCache is enabled (or any other cache implementing Symfony\\Component\\Validator\\Mapping\\Cache\\CacheInterface), some information is lost during serialization (the collectionCascaded and the collectionCascadedDeeply fields).
As a consequence, arrays or traversable objects stored in fields using the @Valid constraint are not traversed by the validator as soon as the validator configuration is loaded from the cache.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/validator | ≥ 2.0.0&&< 2.0.24 | 2.0.24composer require symfony/validator:^2.0.24 |
| 🐘Packagist | symfony/validator | ≥ 2.1.0&&< 2.1.12 | 2.1.12composer require symfony/validator:^2.1.12 |
| 🐘Packagist | symfony/validator | ≥ 2.2.0&&< 2.2.5 | 2.2.5composer require symfony/validator:^2.2.5 |
| 🐘Packagist | symfony/validator | ≥ 2.3.0&&< 2.3.3 | 2.3.3composer require symfony/validator:^2.3.3 |
| 🐘Packagist | symfony/symfony | ≥ 2.0.0&&< 2.0.24 | 2.0.24composer require symfony/symfony:^2.0.24 |
| 🐘Packagist | symfony/symfony | ≥ 2.1.0&&< 2.1.12 | 2.1.12composer require symfony/symfony:^2.1.12 |
Affected Products
fedorafedoraprojectenterprise linuxredhatsymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/validator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/validator to 2.0.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4751 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2013-4751 in your dependencies?
Find it across Packagist, including transitive dependencies.