NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2013-4562 — omniauth-facebook

Fix: mkdynamic/omniauth-facebook@ccfcc26

CVE-2013-4562 is a Cross-Site Request Forgery (CSRF) vulnerability in omniauth-facebook. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for omniauth-facebook — see the affected versions and patch details below.

omniauth-facebook Cross-Site Request Forgery vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.56%1.11%1.67%0.5%1.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💎omniauth-facebook

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The omniauth-facebook gem 1.4.1 before 1.5.0 does not properly store the session parameter, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks via the state parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsomniauth-facebook≥ 1.4.1&&< 1.5.01.5.0bundle update omniauth-facebook --conservative

Affected Products

1 product · 1 configurations
Application
omniauth-facebookmadeofcode
1 version
1.4.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for omniauth-facebook, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update omniauth-facebook to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4562 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The omniauth-facebook gem 1.4.1 before 1.5.0 does not properly store the session parameter, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks via the state parameter.
O3 Security · Impact-Aware SCA

Is CVE-2013-4562 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-4562: omniauth-facebook CSRF — Fixed in 1.5.0