NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2013-4593 — omniauth-facebook

HIGHFix: simi/omniauth-facebook@115c0a7

CVE-2013-4593 is a high-severity (CVSS 7.5) Improper Authentication vulnerability in omniauth-facebook. A fix is available for omniauth-facebook — see the affected versions and patch details below.

omniauth-facebook Improper Authentication vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.75%1.50%2.25%0.4%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎omniauth-facebook

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

RubyGem omniauth-facebook has an access token security vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsomniauth-facebookall versions1.5.1bundle update omniauth-facebook --conservative

Affected Products

1 product · 1 configurations
Application
omniauth-facebookomniauth-facebook_project
≤ 1.5.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for omniauth-facebook, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update omniauth-facebook to 1.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4593 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

RubyGem omniauth-facebook has an access token security vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2013-4593 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-4593: omniauth-facebook — Fixed in 1.5.1