NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2013-4155 — swift

Fix: openstack/swift@1f4ec23

CVE-2013-4155 is a Buffer Overflow vulnerability in swift. A fix is available for swift — see the affected versions and patch details below.

OpenStack Swift allows authenticated users to cause a denial of service

Also known asGHSA-wxx2-gqvv-34hxPYSEC-2026-935
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.51%1.07%1.62%2.18%1.0%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍swift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Swift before 1.9.1 in Folsom, Grizzly, and Havana allows authenticated users to cause a denial of service ("superfluous" tombstone consumption and Swift cluster slowdown) via a DELETE request with a timestamp that is older than expected.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIswiftall versions1.9.1pip install --upgrade 'swift==1.9.1'

Affected Products

4 products · 35 configurations
Application
folsomopenstack
all
Application
grizzlyopenstack
all
Application
havanaopenstack
all
Application
swiftopenstack
≤ 1.9.0
23 versions
1.0.01.0.11.0.21.1.01.2.01.3.01.4.01.4.11.4.21.4.31.4.41.4.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update swift to 1.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4155 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack 3 for RHEL 6openstack-swift-0:1.8.0-7.el6ostRHSA-2013:1197

Frequently Asked Questions

OpenStack Swift before 1.9.1 in Folsom, Grizzly, and Havana allows authenticated users to cause a denial of service ("superfluous" tombstone consumption and Swift cluster slowdown) via a DELETE request with a timestamp that is older than expected.
O3 Security · Impact-Aware SCA

Is CVE-2013-4155 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2013-4155: swift DoS — Fixed in 1.9.1