NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2013-3239 — phpmyadmin

HIGHFix: phpmyadmin/phpmyadmin@d3fafdf

CVE-2013-3239 is a high-severity (CVSS 8.5) Code Injection vulnerability in phpmyadmin/phpmyadmin. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin Remote Code Execution

Also known asGHSA-gg36-9346-9qx9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
7.68%9.59%11.5%13.4%12.3%8.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 3.5.0&&< 3.5.8.13.5.8.1composer require phpmyadmin/phpmyadmin:^3.5.8.1

Affected Products

1 product · 13 configurations
Application
phpmyadminphpmyadmin
12 versions
3.5.0.03.5.1.03.5.2.03.5.2.13.5.2.23.5.3.03.5.43.5.53.5.63.5.73.5.84.0.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-25003webappsphp✓ Verified

phpMyAdmin 3.5.8/4.0.0-RC2 - Multiple Vulnerabilities

by waraxe · Apr 25, 2013

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 3.5.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-3239 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.
O3 Security · Impact-Aware SCA

Is CVE-2013-3239 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-3239: phpmyadmin RCE — Fixed in 3.5.8.1