NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2013-2516 — fileutils

HIGHFix: ruby/fileutils@994c7aa

CVE-2013-2516 is a high-severity (CVSS 8.8) CWE-77 vulnerability in fileutils. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for fileutils — see the affected versions and patch details below.

Fileutils Command Injection vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
1.88%2.53%3.18%3.83%2.4%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎fileutils

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Vulnerability in FileUtils v0.7, Ruby Gem Fileutils <= v0.7 Command Injection vulnerability in user supplied url variable that is passed to the shell.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsfileutilsall versions0.7.1bundle update fileutils --conservative

Affected Products

1 product · 1 configurations
Application
fileutilsfileutils_project
≤ 0.7
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fileutils, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fileutils to 0.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2516 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Ruby Gem Fileutils prior to v0.7.1 contains a Command Injection vulnerability in user supplied url variable that is passed to the shell.
O3 Security · Impact-Aware SCA

Is CVE-2013-2516 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-2516: fileutils — Fixed in 0.7.1