CVE-2013-2161 — swift
Fix: openstack/swift@6659382CVE-2013-2161 is a Code Injection vulnerability in swift. A fix is available for swift — see the affected versions and patch details below.
OpenStack Swift Unchecked user input in XML responses
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
swiftReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
XML injection vulnerability in account/utils.py in OpenStack Swift Folsom, Grizzly, and Havana allows attackers to trigger invalid or spoofed Swift responses via an account name.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | swift | all versions | 1.9.0pip install --upgrade 'swift==1.9.0' |
Affected Products
folsomopenstackgrizzlyopenstackhavanaopenstackopensuseopensuseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update swift to 1.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2161 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Red Hat Security Response Team has rated this issue as having moderate security impact in OpenStack Essex (1.0) and Openstack Folsom (2.1). A future update may address this issue. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack 3 for RHEL 6 | openstack-swift-0:1.8.0-6.el6ost | RHSA-2013:0993 |
Frequently Asked Questions
Is CVE-2013-2161 in your dependencies?
Find it across PyPI, including transitive dependencies.