CVE-2012-5625 — nova
Fix: openstack/nova@9d2ea97CVE-2012-5625 is a CWE-212 vulnerability in nova. A fix is available for nova — see the affected versions and patch details below.
OpenStack Nova Information leak in libvirt LVM-backed instances
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
novaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Compute (Nova) Folsom before 2012.2.2 and Grizzly, when using libvirt and LVM backed instances, does not properly clear physical volume (PV) content when reallocating for instances, which allows attackers to obtain sensitive information by reading the memory of the previous logical volume (LV).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nova | all versions | 12.0.0a0pip install --upgrade 'nova==12.0.0a0' |
Affected Products
folsomopenstackgrizzlyopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nova to 12.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-5625 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2012-5625 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack Folsom for RHEL 6 | openstack-nova-0:2012.2.2-8.el6ost | RHSA-2013:0208 |
Frequently Asked Questions
Is CVE-2012-5625 in your dependencies?
Find it across PyPI, including transitive dependencies.