NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2012-5482 — glance

Fix: openstack/glance@b591304

CVE-2012-5482 is a CWE-264 vulnerability in glance. A fix is available for glance — see the affected versions and patch details below.

OpenStack Glance arbitrary deletion of non-protected images

Also known asGHSA-vwr9-9f8v-vp5m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.90%1.68%2.46%3.25%1.4%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍glance

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The v2 API in OpenStack Glance Grizzly, Folsom (2012.2), and Essex (2012.1) allows remote authenticated users to delete arbitrary non-protected images via an image deletion request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-4573.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIglanceall versions11.0.0a0pip install --upgrade 'glance==11.0.0a0'

Affected Products

3 products · 3 configurations
Application
essexopenstack
1 version
2012.1
Application
folsomopenstack
1 version
2012.2
Application
image registry and delivery service \(glance\)openstack
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for glance, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update glance to 11.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-5482 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The v2 API in OpenStack Glance Grizzly, Folsom (2012.2), and Essex (2012.1) allows remote authenticated users to delete arbitrary non-protected images via an image deletion request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-4573.
O3 Security · Impact-Aware SCA

Is CVE-2012-5482 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-5482: glance — Fixed in 11.0.0a0