CVE-2012-3361 — nova
Fix: openstack/nova@2427d4aCVE-2012-3361 is a CWE-264 vulnerability in nova. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nova — see the affected versions and patch details below.
OpenStack Nova Arbitrary file injection/corruption through directory traversal issues
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
novaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
virt/disk/api.py in OpenStack Compute (Nova) Folsom (2012.2), Essex (2012.1), and Diablo (2011.3) allows remote authenticated users to overwrite arbitrary files via a symlink attack on a file in an image.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nova | all versions | 12.0.0a0pip install --upgrade 'nova==12.0.0a0' |
Affected Products
diabloopenstackessexopenstackfolsomopenstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nova to 12.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-3361 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2012-3361 in your dependencies?
Find it across PyPI, including transitive dependencies.