NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2012-1006 — struts2-parent

CVE-2012-1006 is a Cross-site Scripting (XSS) vulnerability in org.apache.struts:struts2-parent. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.struts:struts2-parent — see the affected versions and patch details below.

Apache Struts Multiple Cross-site Scripting Vulnerabilities

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
56.6%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
50.2%61.6%73.1%84.5%78.1%56.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.struts:struts2-parent☕org.apache.struts:struts2-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.14 and 2.2.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name or (2) lastName parameter to struts2-showcase/person/editPerson.action, or the (3) clientName parameter to struts2-rest-showcase/orders.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.struts:struts2-parentall versions2.1.2org.apache.struts:struts2-parent:2.1.2
☕Mavenorg.apache.struts:struts2-parent≥ 2.2&&< 2.2.3.12.2.3.1org.apache.struts:struts2-parent:2.2.3.1

Affected Products

1 product · 2 configurations
Application
strutsapache
2 versions
2.0.142.2.3
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-18452webappsmultiple

Apache Struts - Multiple Persistent Cross-Site Scripting Vulnerabilities

by SecPod Research · Feb 2, 2012

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.struts:struts2-parent to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1006 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.14 and 2.2.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name or (2) lastName parameter to `struts2-showcase/person/editPerson.action`, or the (3) clientName parameter to `struts2-rest-showcase/orders`.
O3 Security · Impact-Aware SCA

Is CVE-2012-1006 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2012-1006: struts2-parent XSS — Fixed in 2.1.2