CVE-2011-4634 — phpmyadmin
CVE-2011-4634 is a Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
phpMyAdmin vulnerable to Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted database name, related to the Database Synchronize panel; (2) a crafted database name, related to the Database rename panel; (3) a crafted SQL query, related to the table overview panel; (4) a crafted SQL query, related to the view creation dialog; (5) a crafted column type, related to the table search dialog; or (6) a crafted column type, related to the create index dialog.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 3.4.0&&< 3.4.8 | 3.4.8composer require phpmyadmin/phpmyadmin:^3.4.8 |
Affected Products
phpmyadminphpmyadminResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 3.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4634 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2011-4634 in your dependencies?
Find it across Packagist, including transitive dependencies.