NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2011-4461 — jetty-server

MEDIUMFix: eclipse/jetty.project@085c79d

CVE-2011-4461 is a medium-severity (CVSS 5.3) CWE-310 vulnerability in org.eclipse.jetty:jetty-server. A fix is available for org.eclipse.jetty:jetty-server — see the affected versions and patch details below.

Improper Input Validation in Jetty

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
2.39%3.48%4.57%5.66%3.0%4.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.eclipse.jetty:jetty-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jetty 8.1.0.RC2 and earlier computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.eclipse.jetty:jetty-serverall versions8.1.0.RC4org.eclipse.jetty:jetty-server:8.1.0.RC4

Affected Products

2 products · 341 configurations
Application
jettymortbay
≤ 8.1.0
194 versions
1.01.0.11.11.1.11.2.01.3.01.3.11.3.21.3.31.3.41.3.52.0
Application
sun storage common array manageroracle
1 version
6.9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.eclipse.jetty:jetty-server to 8.1.0.RC4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4461 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

The Red Hat Security Response Team has rated this issue as having Low security impact for the jetty-eclipse package in Red Hat Enterprise Linux 6. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Issue Severity Classification:…

Frequently Asked Questions

Jetty 8.1.0.RC2 and earlier computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.
O3 Security · Impact-Aware SCA

Is CVE-2011-4461 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2011-4461: jetty-server DoS — Fixed in 8.1.0.RC4