CVE-2011-3591 — phpmyadmin
Fix: phpmyadmin/phpmyadmin@bda213cCVE-2011-3591 is a Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
phpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Save
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 3.4.0&&< 3.4.5 | 3.4.5composer require phpmyadmin/phpmyadmin:^3.4.5 |
Affected Products
phpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 3.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-3591 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2011-3591 in your dependencies?
Find it across Packagist, including transitive dependencies.