NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2011-3587 — zope2

Fix: zopefoundation/Zope@491a583

CVE-2011-3587 is a security vulnerability in zope2. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for zope2 — see the affected versions and patch details below.

Zope Command Execution Vulnerability

Also known asPYSEC-2026-1067
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
78.1%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
74.4%81.0%87.6%94.2%90.5%78.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐍zope2🐍zope2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the p_ class in OFS/misc_.py and the use of Python modules.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIzope2≥ 2.12.0&&< 2.12.202.12.20pip install --upgrade 'zope2==2.12.20'
🐍PyPIzope2≥ 2.13.0&&< 2.13.102.13.10pip install --upgrade 'zope2==2.13.10'

Affected Products

2 products · 60 configurations
Application
ploneplone
14 versions
4.04.0.14.0.24.0.34.0.44.0.54.0.6.14.0.74.0.84.0.94.14.2
Application
zopezope
32 versions
2.12.02.12.12.12.22.12.32.12.42.12.52.12.62.12.72.12.82.12.92.12.102.12.11
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-18262webappsmultiple✓ Verified

Plone and Zope - Remote Command Execution

by Nick Miles · Dec 21, 2011

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zope2 to 2.12.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-3587 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the `p_` class in `OFS/misc_.py` and the use of Python modules.
O3 Security · Impact-Aware SCA

Is CVE-2011-3587 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2011-3587: zope2 — Fixed in 2.12.20