CVE-2006-4684 — zope2
CVE-2006-4684 is a security vulnerability in zope2. A fix is available for zope2 — see the affected versions and patch details below.
Zope allows remote attackers to read arbitrary files
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
zope2🐍zope2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The docutils module in Zope (Zope2) 2.7.0 through 2.7.9 and 2.8.0 through 2.8.8 does not properly handle web pages with reStructuredText (reST) markup, which allows remote attackers to read arbitrary files via a csv_table directive, a different vulnerability than CVE-2006-3458.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | zope2 | ≥ 2.7.0 | No fix |
| 🐍PyPI | zope2 | ≥ 2.8.0&&< 2.8.9 | 2.8.9pip install --upgrade 'zope2==2.8.9' |
Affected Products
zopezopeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2006-4684; check the affected-versions list above or the advisory for the patched release of zope2, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2006-4684 in your dependencies?
Find it across PyPI, including transitive dependencies.