NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2011-2935 — elgg

MEDIUMFix: Elgg/Elgg@2843b4f

CVE-2011-2935 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in elgg/elgg. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for elgg/elgg — see the affected versions and patch details below.

Elgg Reflected XSS Vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.04%1.56%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘elgg/elgg

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

VULNERABILITY DESCRIPTION

The internalname parameter is not properly sanitized, which allows attacker to conduct Cross Site Scripting attack. This may allow an attacker to create a specially crafted URL that would execute arbitrary script code in a victim's browser

PROOF-OF-CONCEPT/EXPLOIT

http://localhost/pg/embed/media?internalname=%20%22onmouseover=%22alert%28/XSS/%29%22style=%22width:3000px!important;height:3000px!important;z-index:999999;position:absolute!important;left:0;top:0;%22%20x=%22

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistelgg/elggall versions1.7.11composer require elgg/elgg:^1.7.11

Affected Products

1 product · 1 configurations
Application
elggelgg
≤ 1.7.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for elgg/elgg, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update elgg/elgg to 1.7.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2935 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### VULNERABILITY DESCRIPTION The `internalname` parameter is not properly sanitized, which allows attacker to conduct Cross Site Scripting attack. This may allow an attacker to create a specially crafted URL that would execute arbitrary script code in a victim's browser ### PROOF-OF-CONCEPT/EXPLOIT ```http http://localhost/pg/embed/media?internalname=%20%22onmouseover=%22alert%28/XSS/%29%22style=%22width:3000px!important;height:3000px!important;z-index:999999;position:absolute!important;left:0;top:0;%22%20x=%22 ```
O3 Security · Impact-Aware SCA

Is CVE-2011-2935 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2011-2935: elgg XSS — Fixed in 1.7.11