CVE-2011-2506 — phpmyadmin
Fix: phpmyadmin/phpmyadmin@0fbedafCVE-2011-2506 is a Code Injection vulnerability in phpmyadmin/phpmyadmin. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
phpMyAdmin vulnerable to static code injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of comment closing delimiters, which allows remote attackers to conduct static code injection attacks by leveraging the ability to modify the SESSION superglobal array.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 3.0&&< 3.3.10.2 | 3.3.10.2composer require phpmyadmin/phpmyadmin:^3.3.10.2 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 3.4&&< 3.4.3.1 | 3.4.3.1composer require phpmyadmin/phpmyadmin:^3.4.3.1 |
Affected Products
phpmyadminphpmyadminResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
phpMyAdmin 3.x - Swekey Remote Code Injection
by Mango · Jul 9, 2011
phpMyAdmin3 (pma3) - Remote Code Execution
by wofeiwo · Jul 8, 2011
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 3.3.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2506 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2011-2506 in your dependencies?
Find it across Packagist, including transitive dependencies.