NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2011-2505 — phpmyadmin

Fix: phpmyadmin/composer@7ebd958

CVE-2011-2505 is a Code Injection vulnerability in phpmyadmin/phpmyadmin. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin remote variable manipulation

Also known asGHSA-vqcm-r62w-w437
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
4 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
12.9%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
5.64%18.5%31.4%44.2%37.0%12.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 3.0&&< 3.3.10.23.3.10.2composer require phpmyadmin/phpmyadmin:^3.3.10.2
🐘Packagistphpmyadmin/phpmyadmin≥ 3.4&&< 3.4.3.13.4.3.1composer require phpmyadmin/phpmyadmin:^3.4.3.1

Affected Products

1 product · 48 configurations
Application
phpmyadminphpmyadmin
34 versions
3.0.03.0.13.0.1.13.1.03.1.13.1.23.1.33.1.3.13.1.3.23.1.43.1.53.2.0
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-17514webappsphp✓ Verified

phpMyAdmin 3.x - Swekey Remote Code Injection

by Mango · Jul 9, 2011

EDB-17510webappsphp✓ Verified

phpMyAdmin3 (pma3) - Remote Code Execution

by wofeiwo · Jul 8, 2011

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 3.3.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2505 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."
O3 Security · Impact-Aware SCA

Is CVE-2011-2505 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2011-2505: phpmyadmin — Fixed in 3.3.10.2