NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2011-10026 — spree

Fix: spree/spree@0a9a360

CVE-2011-10026 is a OS Command Injection vulnerability in spree. A fix is available for spree — see the affected versions and patch details below.

Spree Commerce is vulnerable to RCE through Search API

Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2011-10026.

EPSS Exploitation Probability

via FIRST.org ↗
3.8%probability of exploitation in next 30 days
Lower Risk+1.12%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%29.5%59.0%88.5%65.4%3.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
💎spree💎rd_searchlogic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. Improper input sanitation allows attackers to inject arbitrary shell commands via the search[instance_eval] parameter, which is dynamically invoked using Ruby’s send method. This flaw enables unauthenticated attackers to execute commands on the server.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsspree≥ 0.30.0.beta1&&< 0.50.00.50.0bundle update spree --conservative
💎RubyGemsrd_searchlogicall versionsNo fix

Affected Products

1 product · 1 configurations
Application
spreespreecommerce
< 0.50.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for spree, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update spree to 0.50.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-10026 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. Improper input sanitation allows attackers to inject arbitrary shell commands via the search[instance_eval] parameter, which is dynamically invoked using Ruby’s send method. This flaw enables unauthenticated attackers to execute commands on the server.
O3 Security · Impact-Aware SCA

Is CVE-2011-10026 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2011-10026: spree — Fixed in 0.50.0