CVE-2010-3978 — spree
Fix: railsdog/spree@19944bdCVE-2010-3978 is a Information Exposure vulnerability in spree. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for spree — see the affected versions and patch details below.
Spree allows remote attackers to obtain sensitive information
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
spree💎spreeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Spree 0.11.x before 0.11.2 and 0.30.x before 0.30.0 exchanges data using JavaScript Object Notation (JSON) without a mechanism for validating requests, which allows remote attackers to obtain sensitive information via vectors involving (1) admin/products.json, (2) admin/users.json, or (3) admin/overview/get_report_data, related to a "JSON hijacking" issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | spree | ≥ 0.11.0&&< 0.11.2 | 0.11.2bundle update spree --conservative |
| 💎RubyGems | spree | ≥ 0.30.0.beta1&&< 0.30.0 | 0.30.0bundle update spree --conservative |
Affected Products
spreespreecommerceResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for spree, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update spree to 0.11.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3978 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2010-3978 in your dependencies?
Find it across RubyGems, including transitive dependencies.