NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2011-0451 — ec-cube

Fix: EC-CUBE/ec-cube@8ef6541

CVE-2011-0451 is a Cross-site Scripting (XSS) vulnerability in ec-cube/ec-cube. A fix is available for ec-cube/ec-cube — see the affected versions and patch details below.

EC-CUBE XSS Vulnerabilities

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.81%1.62%2.44%0.4%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘ec-cube/ec-cube

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in (1) data/Smarty/templates/default/list.tpl and (2) data/Smarty/templates/default/campaign/bloc/cart_tag.tpl in EC-CUBE before 2.4.4 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistec-cube/ec-cubeall versions2.4.4composer require ec-cube/ec-cube:^2.4.4

Affected Products

1 product · 42 configurations
Application
ec-cubelockon
≤ 2.4.3
31 versions
1.1.01.1.11.2.01.3.01.3.11.3.21.3.31.3.41.4.01.4.11.4.21.4.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ec-cube/ec-cube, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ec-cube/ec-cube to 2.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-0451 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in (1) `data/Smarty/templates/default/list.tpl` and (2) `data/Smarty/templates/default/campaign/bloc/cart_tag.tpl` in EC-CUBE before 2.4.4 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2011-0451 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2011-0451: ec-cube XSS — Fixed in 2.4.4