CVE-2010-1649 — joomla-cms
CVE-2010-1649 is a Cross-site Scripting (XSS) vulnerability in joomla/joomla-cms. A fix is available for joomla/joomla-cms — see the affected versions and patch details below.
Joomla! vulnerable to Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
joomla/joomla-cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in the back end in Joomla! 1.5 through 1.5.17 allow remote attackers to inject arbitrary web script or HTML via unknown vectors related to "various administrator screens," possibly the search parameter in administrator/index.php.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | joomla/joomla-cms | ≥ 1.5&&< 1.5.18 | 1.5.18composer require joomla/joomla-cms:^1.5.18 |
Affected Products
joomla\!joomlaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for joomla/joomla-cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update joomla/joomla-cms to 1.5.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-1649 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2010-1649 in your dependencies?
Find it across Packagist, including transitive dependencies.