CVE-2019-16725 — joomla-cms
MEDIUMCVE-2019-16725 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in joomla/joomla-cms. A fix is available for joomla/joomla-cms — see the affected versions and patch details below.
Joomla! XSS in Default Templates
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
joomla/joomla-cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Joomla! 3.x before 3.9.12, inadequate escaping allowed XSS attacks using the logo parameter of the default templates.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | joomla/joomla-cms | ≥ 3.0.0&&< 3.9.12 | 3.9.12composer require joomla/joomla-cms:^3.9.12 |
Affected Products
joomla\!joomlaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for joomla/joomla-cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update joomla/joomla-cms to 3.9.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16725 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2019-16725 in your dependencies?
Find it across Packagist, including transitive dependencies.