NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-1149 — phpmyadmin

Fix: phpmyadmin/phpmyadmin@69bfbf1

CVE-2009-1149 is a Improper Input Validation vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin HTTP Response Splitting Vulnerability

Also known asGHSA-xrpq-63mp-9vcw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.21%0.79%1.36%1.93%0.7%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CRLF injection vulnerability in bs_disp_as_mime_type.php in the BLOB streaming feature in phpMyAdmin before 3.1.3.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the (1) c_type and possibly (2) file_type parameters.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadminall versions3.1.3.1composer require phpmyadmin/phpmyadmin:^3.1.3.1

Affected Products

1 product · 8 configurations
Application
phpmyadminphpmyadmin
≤ 3.1.3
5 versions
3.1.03.1.0.03.1.13.1.23.1.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 3.1.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-1149 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

CRLF injection vulnerability in bs_disp_as_mime_type.php in the BLOB streaming feature in phpMyAdmin before 3.1.3.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the (1) c_type and possibly (2) file_type parameters.
O3 Security · Impact-Aware SCA

Is CVE-2009-1149 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-1149: phpmyadmin — Fixed in 3.1.3.1