CVE-2006-6969 — jetty-server
Fix: jetty-project/codehaus-jetty6@36f81d2CVE-2006-6969 is a security vulnerability in org.eclipse.jetty:jetty-server. A fix is available for org.eclipse.jetty:jetty-server — see the affected versions and patch details below.
Jetty Uses Predictable Session Identifiers
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jetty before 4.2.27, 5.1 before 5.1.12, 6.0 before 6.0.2, and 6.1 before 6.1.0pre3 generates predictable session identifiers using java.util.random, which makes it easier for remote attackers to guess a session identifier through brute force attacks, bypass authentication requirements, and possibly conduct cross-site request forgery attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-server | all versions | 4.2.27org.eclipse.jetty:jetty-server:4.2.27 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 5.1.0&&< 5.1.12 | 5.1.12org.eclipse.jetty:jetty-server:5.1.12 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 6.0.0&&< 6.0.2 | 6.0.2org.eclipse.jetty:jetty-server:6.0.2 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 6.1.0pre1&&< 6.1.0pre3 | 6.1.0pre3org.eclipse.jetty:jetty-server:6.1.0pre3 |
Affected Products
jetty http serverjettyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-server to 4.2.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2006-6969 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2006-6969 in your dependencies?
Find it across Maven, including transitive dependencies.