NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2006-5031 — cakephp

CVE-2006-5031 is a Path Traversal vulnerability in cakephp/cakephp. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for cakephp/cakephp — see the affected versions and patch details below.

CakePHP directory traversal vulnerability allows remote attackers to read arbitrary files

Also known asGHSA-rw73-xmpv-j5x2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.7%probability of exploitation in next 30 days
Lower Risk+0.14%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
6.38%6.98%7.58%8.17%6.9%7.7%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘cakephp/cakephp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Directory traversal vulnerability in app/webroot/js/vendors.php in Cake Software Foundation CakePHP before 1.1.8.3544 allows remote attackers to read arbitrary files via a .. (dot dot) in the file parameter, followed by a filename ending with "%00" and a .js filename.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcakephp/cakephp≥ 1.0.1.2708&&< 1.1.8.35441.1.8.3544composer require cakephp/cakephp:^1.1.8.3544

Affected Products

1 product · 1 configurations
Application
cakephpcakephp
≤ 1.1.7.3363
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-28645webappsphp✓ Verified

CakePHP 1.1.7.3363 - 'Vendors.php' Directory Traversal

by GulfTech Security · Sep 22, 2006

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cakephp/cakephp to 1.1.8.3544 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2006-5031 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Directory traversal vulnerability in app/webroot/js/vendors.php in Cake Software Foundation CakePHP before 1.1.8.3544 allows remote attackers to read arbitrary files via a .. (dot dot) in the file parameter, followed by a filename ending with "%00" and a .js filename.
O3 Security · Impact-Aware SCA

Is CVE-2006-5031 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2006-5031: cakephp — Fixed in 1.1.8.3544