NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2006-4067 — cakephp

MEDIUM

CVE-2006-4067 is a medium-severity (CVSS 6.5) Cross-site Scripting (XSS) vulnerability in cakephp/cakephp. A fix is available for cakephp/cakephp — see the affected versions and patch details below.

Cross-site scripting (XSS) vulnerability in CakePHP

Also known asGHSA-vc29-mvwv-wpcq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.57%1.14%1.71%0.4%1.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘cakephp/cakephp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 ("Not Found") error page. NOTE: some of these details are obtained from third party information.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcakephp/cakephp≥ 1.0.1.2708&&< 1.1.7.33631.1.7.3363composer require cakephp/cakephp:^1.1.7.3363

Affected Products

1 product · 5 configurations
Application
cakephpcakephp
≤ 1.1.6.3264
4 versions
1.0.1.27081.1.3.29671.1.4.31041.1.5.3148

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cakephp/cakephp to 1.1.7.3363 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2006-4067 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 ("Not Found") error page. NOTE: some of these details are obtained from third party information.
O3 Security · Impact-Aware SCA

Is CVE-2006-4067 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2006-4067: cakephp XSS — Fixed in 1.1.7.3363