NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2006-3360 — phpsysinfo

Fix: phpsysinfo/phpsysinfo@60b5bbb

CVE-2006-3360 is a Path Traversal vulnerability in phpsysinfo/phpsysinfo. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpsysinfo/phpsysinfo — see the affected versions and patch details below.

phpSysInfo allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence

Also known asGHSA-2wxv-3g4v-p76p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
4.62%5.95%7.28%8.61%7.9%5.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘phpsysinfo/phpsysinfo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Directory traversal vulnerability in index.php in phpSysInfo prior to 3.2.5 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpsysinfo/phpsysinfoall versions3.2.5composer require phpsysinfo/phpsysinfo:^3.2.5

Affected Products

1 product · 1 configurations
Application
phpsysinfophpsysinfo
≤ 2.5.1
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpsysinfo/phpsysinfo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpsysinfo/phpsysinfo to 3.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2006-3360 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Directory traversal vulnerability in index.php in phpSysInfo prior to 3.2.5 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.
O3 Security · Impact-Aware SCA

Is CVE-2006-3360 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2006-3360: phpsysinfo Path Traversal — Fixed in 3.2.5