NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-49006 — phpsysinfo

MEDIUMFix: phpsysinfo/phpsysinfo@4f2cee5

CVE-2023-49006 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in phpsysinfo/phpsysinfo. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpsysinfo/phpsysinfo — see the affected versions and patch details below.

Phpsysinfo Cross Site Request Forgery (CSRF) vulnerability

Also known asGHSA-67gv-xrw7-p72w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.68%1.02%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpsysinfo/phpsysinfo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross Site Request Forgery (CSRF) vulnerability in Phpsysinfo version 3.4.3 allows a remote attacker to obtain sensitive information via a crafted page in the XML.php file. Phpsysinfo 3.4.3 disables the functionality by default but the users may enable the vulnerable functionality.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpsysinfo/phpsysinfoall versions3.4.3composer require phpsysinfo/phpsysinfo:^3.4.3

Affected Products

1 product · 1 configurations
Application
phpsysinfophpsysinfo
1 version
3.4.3
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpsysinfo/phpsysinfo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpsysinfo/phpsysinfo to 3.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-49006 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Cross Site Request Forgery (CSRF) vulnerability in Phpsysinfo version 3.4.3 allows a remote attacker to obtain sensitive information via a crafted page in the XML.php file. Phpsysinfo 3.4.3 disables the functionality by default but the users may enable the vulnerable functionality.
O3 Security · Impact-Aware SCA

Is CVE-2023-49006 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-49006: phpsysinfo CSRF — Fixed in 3.4.3