silverstripe/framework SQL injection in full text searchGHSA-xx4r-5265-48j6
HIGHFix: silverstripe/silverstripe-framework@099a5a3GHSA-xx4r-5265-48j6 is a high-severity (CVSS 8.8) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Real-World Exposure
silverstripe/framework🐘silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
When performing a fulltext search in SilverStripe 4.0.0 the 'start' querystring parameter is never escaped safely. This exposes a possible SQL injection vulnerability.
The issue exists in 3.5 and 3.6 but is less vulnerable, as SearchForm sanitises these variables prior to passing to mysql.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 3.5.0-rc1&&< 3.5.6 | 3.5.6composer require silverstripe/framework:^3.5.6 |
| 🐘Packagist | silverstripe/framework | ≥ 3.6.0-rc1&&< 3.6.3 | 3.6.3composer require silverstripe/framework:^3.6.3 |
| 🐘Packagist | silverstripe/framework | ≥ 4.0.0-rc1&&< 4.0.1 | 4.0.1composer require silverstripe/framework:^4.0.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.5.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xx4r-5265-48j6 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is GHSA-xx4r-5265-48j6 in your dependencies?
Find it across Packagist, including transitive dependencies.