FractionalMaxPool and FractionalAVGPool heap out-of-bounds acessGHSA-xvwp-h6jv-7472
HIGHFix: tensorflow/tensorflow@2165251GHSA-xvwp-h6jv-7472 is a high-severity (CVSS 7.1) Out-of-bounds Read vulnerability in tensorflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An input pooling_ratio that is smaller than 1 will trigger a heap OOB in tf.raw_ops.FractionalMaxPool and tf.raw_ops.FractionalAvgPool.
Patches
We have patched the issue in GitHub commit 216525144ee7c910296f5b05d214ca1327c9ce48.
The fix will be included in TensorFlow 2.11.0. We will also cherry pick this commit on TensorFlow 2.10.1.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.8.4pip install --upgrade 'tensorflow==2.8.4' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.3 | 2.9.3pip install --upgrade 'tensorflow==2.9.3' |
| 🐍PyPI | tensorflow | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow==2.10.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.8.4pip install --upgrade 'tensorflow-cpu==2.8.4' |
| 🐍PyPI | tensorflow-gpu | all versions | 2.8.4pip install --upgrade 'tensorflow-gpu==2.8.4' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.3 | 2.9.3pip install --upgrade 'tensorflow-cpu==2.9.3' |
Affected Products
tensorflowgoogleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xvwp-h6jv-7472 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-xvwp-h6jv-7472 in your dependencies?
Find it across PyPI, including transitive dependencies.