CVE-2023-25658 is a high-severity (CVSS 7.5) Out-of-bounds Read vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.
TensorFlow vulnerable to Out-of-Bounds Read in GRUBlockCellGrad
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-25658.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow-cpu🐍tensorflow-gpuReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Out of bounds read in GRUBlockCellGrad
func = tf.raw_ops.GRUBlockCellGrad
para = {'x': [[21.1, 156.2], [83.3, 115.4]], 'h_prev': array([[136.5],
[136.6]]), 'w_ru': array([[26.7, 0.8],
[47.9, 26.1],
[26.2, 26.3]]), 'w_c': array([[ 0.4],
[31.5],
[ 0.6]]), 'b_ru': array([0.1, 0.2 ], dtype=float32), 'b_c': 0x41414141, 'r': array([[0.3],
[0.4]], dtype=float32), 'u': array([[5.7],
[5.8]]), 'c': array([[52.9],
[53.1]]), 'd_h': array([[172.2],
[188.3 ]])}
Patches
We have patched the issue in GitHub commit ff459137c2716a2a60f7d441b855fcb466d778cb.
The fix will be included in TensorFlow 2.12.0. We will also cherrypick this commit on TensorFlow 2.11.1
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by r3pwnx.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.11.1pip install --upgrade 'tensorflow==2.11.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.11.1pip install --upgrade 'tensorflow-cpu==2.11.1' |
| 🐍PyPI | tensorflow-gpu | all versions | 2.11.1pip install --upgrade 'tensorflow-gpu==2.11.1' |
Affected Products
tensorflowgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-25658 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2023-25658 in your dependencies?
Find it across PyPI, including transitive dependencies.