NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

TensorFlow vulnerable to Out-of-Bounds Read in GRUBlockCellGradGHSA-68v3-g9cm-rmm6

HIGHFix: tensorflow/tensorflow@ff45913

GHSA-68v3-g9cm-rmm6 is a high-severity (CVSS 7.5) Out-of-bounds Read vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.

Also known asBIT-tensorflow-2023-25658CVE-2023-25658PYSEC-2026-3120PYSEC-2026-3286PYSEC-2026-960
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-68v3-g9cm-rmm6.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.30%0.59%0.89%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Out of bounds read in GRUBlockCellGrad

func = tf.raw_ops.GRUBlockCellGrad

para = {'x': [[21.1, 156.2], [83.3, 115.4]], 'h_prev': array([[136.5],
      [136.6]]), 'w_ru': array([[26.7,  0.8],
      [47.9, 26.1],
      [26.2, 26.3]]), 'w_c': array([[ 0.4],
      [31.5],
      [ 0.6]]), 'b_ru': array([0.1, 0.2 ], dtype=float32), 'b_c': 0x41414141, 'r': array([[0.3],
      [0.4]], dtype=float32), 'u': array([[5.7],
      [5.8]]), 'c': array([[52.9],
      [53.1]]), 'd_h': array([[172.2],
      [188.3 ]])}

Patches

We have patched the issue in GitHub commit ff459137c2716a2a60f7d441b855fcb466d778cb.

The fix will be included in TensorFlow 2.12.0. We will also cherrypick this commit on TensorFlow 2.11.1

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by r3pwnx.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.11.1pip install --upgrade 'tensorflow==2.11.1'
🐍PyPItensorflow-cpuall versions2.11.1pip install --upgrade 'tensorflow-cpu==2.11.1'
🐍PyPItensorflow-gpuall versions2.11.1pip install --upgrade 'tensorflow-gpu==2.11.1'

Affected Products

1 product · 1 configurations
Application
tensorflowgoogle
< 2.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-68v3-g9cm-rmm6 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

### Impact Out of bounds read in GRUBlockCellGrad ```python func = tf.raw_ops.GRUBlockCellGrad para = {'x': [[21.1, 156.2], [83.3, 115.4]], 'h_prev': array([[136.5], [136.6]]), 'w_ru': array([[26.7, 0.8], [47.9, 26.1], [26.2, 26.3]]), 'w_c': array([[ 0.4], [31.5], [ 0.6]]), 'b_ru': array([0.1, 0.2 ], dtype=float32), 'b_c': 0x41414141, 'r': array([[0.3], [0.4]], dtype=float32), 'u': array([[5.7], [5.8]]), 'c': array([[52.9], [53.1]]), 'd_h': array([[172.2], [188.3 ]])} ``` ### Patches We have patched the issue in GitHub commit [ff459137c2
O3 Security · Impact-Aware SCA

Is GHSA-68v3-g9cm-rmm6 in your dependencies?

Find it across PyPI, including transitive dependencies.

TensorFlow vulnerable to Out-of-Bounds Read in…